Q: I have an HP running Windows 10. I use Outlook for email. When I click on a link in an email message, I am directed to my homepage rather than the link. I have a laptop using the same setup, but it works as it should.

– Bill H., Niceville

A: It always helps me to know as much as possible, not only about your problem, but also about the computer and software that you’re running when the problem occurs. Case in point, Bill, by my count there have been at least 11 versions of Outlook between its release in 1997 and the latest version included in Office 365, and I have no idea which one you’re using. While they all do the same basic task of receiving, sending, and organizing email (among other things), the versions are distinct enough that when I’m researching a problem and putting together comprehensive remediation steps it makes a difference which one you’re running. Worse for me is not knowing what software is the default web browser on your computer, since problems like this, and the procedures to fix them, will probably be different depending on whether you’re running Microsoft Edge, Windows Explorer, Google Chrome, or some other browser. So, Bill, and all my dear Geeks, as I’ve said in the past, when contacting me for assistance, please include as much information as you can to help me do a better job of helping you.

Speaking of things I’ve said in the past, yours is not the first question I’ve fielded about hyperlinks not working properly in Outlook. I suggest you visit my website and read Issue No. 587 (Geek Note: I.G.T.M. No. 587, Oct. 27, 2018), as well as another issue to which it refers (I.G.T.M. No. 572, July 14, 2018). The problems discussed in these issues may not be identical to yours, but the suggestions are probably a good place to start for your issue as well. At a minimum, they won’t hurt anything.

To understand the problem, it might help to understand a little more about what happens when you click on a link. If you are already in a web browser when you perform the click, all that needs to happen is for the browser to do what it does to open and display the page to which the link points. But other applications support displaying hyperlinks. This includes Outlook, Word, and other collaborative programs in which sharing a hyperlink is desirable functionality. When a link is clicked within one of these applications the program informs Windows which in-turn uses configuration data within the Registry to determine which application to open – in this case, the system’s default web browser.

Just because this matter isn’t confusing enough already, let me say that there are multiple ways that a web browser can open. The most basic way is that you clicked its icon on the Windows Start menu, Desktop, or main toolbar. The browser opens, and displays the default page or pages that it’s been programmed to open upon launch (often called your home page). Then there’s the way you mentioned in your question: the browser is launched by Windows in response to a link being clicked in an application other than the browser itself. Assuming the Registry has the correct information, a command line is generated, which includes the full path and filename of the browser executable, plus, a parameter that contains the link to open. When the browser finds a link in the command line, rather than load the home page, it loads the linked page instead.

Knowing this, the problem underlying your issue should become more apparent. Since your browser is not displaying the linked page, we can assume that it is not being correctly informed of the link, so it displays your home page instead. In virtually every instance, the cause of this problem lies within the registry. There is a corrupt or missing entry for the browser, resulting in a defective command line. The above-mentioned issues of I.G.T.M. each contain steps that attempt to perform registry fixes. A corrupt registry entry can manifest in different ways, including what’s happening with your system. So, I would encourage you to try the fixes given in these columns to see if they help. Of course, these fixes are browser-specific, so they may not be exactly what you need. There’s one more solution you can try in an article I found for you at TinyURL/IGTM-0624. Hopefully one of these solutions will work for you.

To view additional content, comment on articles, or submit a question of your own, visit my website at ItsGeekToMe.co (not .com!)