<!doctype html><html lang=en-US class=gnt__njs data-u-s=anon><head><meta charset=utf-8 /><meta name=viewport content="width=device-width,initial-scale=1,minimum-scale=1"/><meta name=theme-color content=#0098FE /><title>DESTIN EVENTS AND ENTERTAINMENT March 20</title><meta property=og:title content="DESTIN EVENTS AND ENTERTAINMENT March 20"/><link rel=amphtml href=https://amp.waltonsun.com/amp/4747189001 /><meta property=article:author content="Pam Griffin"/><meta property=article:content_tier content=metered /><meta property=article:opinion content=false /><link rel=dns-prefetch href=//user.waltonsun.com /><link rel=preconnect href=https://user.waltonsun.com /><link rel=dns-prefetch href=//content-static.gannett.com /><link rel=dns-prefetch href=//www.gannett-cdn.com /><link rel=dns-prefetch href=//securepubads.g.doubleclick.net /><link rel=preconnect href=https://securepubads.g.doubleclick.net /><link rel=dns-prefetch href=//adservice.google.com /><link rel=preconnect href=https://adservice.google.com /><link rel=dns-prefetch href=//tpc.googlesyndication.com /><link rel=preconnect href=https://tpc.googlesyndication.com /><link rel=dns-prefetch href=//googleads.g.doubleclick.net /><link rel=dns-prefetch href=//s0.2mdn.net /><link rel=dns-prefetch href=//partner.googleadservices.com /><link rel=dns-prefetch href=//www.googletagservices.com /><link rel=preconnect href=https://www.googletagservices.com /><link rel=dns-prefetch href=//static.adsafeprotected.com /><link rel=preconnect href=https://static.adsafeprotected.com /><link rel=dns-prefetch href=//pixel.adsafeprotected.com /><link rel=preconnect href=https://pixel.adsafeprotected.com crossorigin/><link rel=dns-prefetch href=//c.amazon-adsystem.com /><link rel=preconnect href=//c.amazon-adsystem.com /><link rel=dns-prefetch href=//js-sec.indexww.com /><link rel=preconnect href=https://js-sec.indexww.com /><link rel=dns-prefetch href=//aax.amazon-adsystem.com /><link rel=preconnect href=//aax.amazon-adsystem.com /><link rel=dns-prefetch href=//fastlane.rubiconproject.com /><link rel=preconnect href=https://fastlane.rubiconproject.com /><link rel=dns-prefetch href=//bidder.criteo.com /><link rel=preconnect href=https://bidder.criteo.com /><link rel=dns-prefetch href=//colossusssp.com /><link rel=preconnect href=https://colossusssp.com /><link rel=dns-prefetch href=//gannett-d.openx.net /><link rel=preconnect href=https://gannett-d.openx.net /><link rel=dns-prefetch href=//hbopenbid.pubmatic.com /><link rel=preconnect href=https://hbopenbid.pubmatic.com /><link rel=dns-prefetch href=//ads.pubmatic.com /><link rel=dns-prefetch href=//as-sec.casalemedia.com /><link rel=preconnect href=https://as-sec.casalemedia.com /><link rel=dns-prefetch href=//ib.adnxs.com /><link rel=preconnect href=https://ib.adnxs.com /><link rel=dns-prefetch href=//adserver.adtechus.com /><link rel=preconnect href=https://adserver.adtechus.com /><link rel=dns-prefetch href=//apex.go.sonobi.com /><link rel=preconnect href=https://apex.go.sonobi.com /><link rel=dns-prefetch href=//sofia.trustx.org /><link rel=preconnect href=https://sofia.trustx.org /><link rel=dns-prefetch href=//tlx.3lift.com /><link rel=preconnect href=https://tlx.3lift.com /><link rel=dns-prefetch href=//e.serverbid.com /><link rel=preconnect href=https://e.serverbid.com /><link rel=dns-prefetch href=//confiant-integrations.global.ssl.fastly.net /><link rel=preconnect href=https://confiant-integrations.global.ssl.fastly.net /><link rel=preconnect href=https://s0.2mdn.net /><link rel=preconnect href=https://ads.adaptv.advertising.com /><link rel=preconnect href=https://search.spotxchange.com /><link rel=preconnect href=https://static.adsafeprotected.com /><link rel=preconnect href=https://imasdk.googleapis.com /><link rel=dns-prefetch href=//ads.adaptv.advertising.com /><link rel=dns-prefetch href=//search.spotxchange.com /><link rel=dns-prefetch href=//static.adsafeprotected.com /><link rel=dns-prefetch href=//imasdk.googleapis.com /><link rel=dns-prefetch href=//a.teads.com /><link rel=dns-prefetch href=//a.teads.tv /><link rel=preconnect href=https://a.teads.tv /><link rel=dns-prefetch href=//geolocation.onetrust.com /><link rel=preconnect href=https://geolocation.onetrust.com /><link rel=dns-prefetch href=//atoms.waltonsun.com /><link rel=dns-prefetch href=//cdn.taboola.com /><link rel=preconnect href=https://cdn.taboola.com /><link rel=dns-prefetch href=//trc.taboola.com /><link rel=preconnect href=https://trc.taboola.com /><link rel=dns-prefetch href=//www.usatodaynetworkservice.com /><link rel=preload as=fetch type=application/json href=https://user.waltonsun.com/NWAL-GUP/user/ crossorigin=use-credentials /><link rel=preload as=script href=/tangstatic/js/pbjsandwich-q1a2z357c67ab5.min.js /><link rel=preload as=script href=https://c.amazon-adsystem.com/aax2/apstag.js /><link rel=preload as=script href=https://js-sec.indexww.com/ht/p/184808-89514051626416.js /><link rel=preload as=script href=https://static.adsafeprotected.com/iasPET.1.js /><link rel=preload as=script href=https://securepubads.g.doubleclick.net/tag/js/gpt.js /><link rel=preload as=script href=https://confiant-integrations.global.ssl.fastly.net/r5TdgVvkbv-PeaJCKaQfCh5Xsto/gpt_and_prebid_v3l/config.js /><link rel=preload as=script href=/tangstatic/js/main-q1a2z3223907d6.min.js /><link rel=preload as=script href=https://geolocation.onetrust.com/cookieconsentpub/v1/geo/location/gnt.otgc /><link rel=preload as=script href=https://cdn.taboola.com/libtrc/gannett-network/loader.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/controls-eb1611d8.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/share-454f9438.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/tealplayer-43a0b741.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/teal-comscore-f1701de9.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/teal-gcianalytics-23c0960c.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/teal-hls-aa645eb8.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/teal-parsely-b3e4ce3e.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/encore-c29e248c.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/teal-ima-ac4c537c.min.js /><link rel=preload as=fetch href="https://hlsmedia.gannett-cdn.com/authoring/video-renditions/0ae2c019-f819-432e-9495-d20fa328350e/612bab3c-e99c-463e-a094-7591d0c1c6a9/1080p_30fps,720p_30fps,480p_30fps,master.m3u8?subtitles=4740330001" crossorigin/><link rel=preload as=script href=/gannett-web/apps/teal/dist/vendor/hls/hls.0.14.9.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/vendor/comscore/streamsense-5.1.1.160316.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/vendor/ias/ias-3.5.1.min.js /><link rel=preload as=script href=https://s0.2mdn.net/instream/video/client.js /><link rel=preload as=script href=https://imasdk.googleapis.com/js/sdkloader/ima3.js /><meta name=description content="DESTIN EVENTS AND ENTERTAINMENT March 20"/><meta property=og:description content="DESTIN EVENTS AND ENTERTAINMENT March 20"/><meta property=fb:pages content=417425655013650 /><meta property=fb:app_id content=596315637658855 /><link rel=canonical href=https://www.waltonsun.com/story/entertainment/2021/03/18/destin-events-and-entertainment-march-20/4747189001/ /><meta property=og:url content=https://www.waltonsun.com/story/entertainment/2021/03/18/destin-events-and-entertainment-march-20/4747189001/ /><meta property=og:site_name content="Walton Sun"/><meta property=og:image content="https://www.gannett-cdn.com/presto/2020/08/13/NDES/94f13d98-9aee-4f68-84be-667c04ad6977-log_com_calendar.jpg?crop=297,168,x0,y0&width=297&height=168&format=pjpg&auto=webp"/><meta property=og:image:width content=297 /><meta property=og:image:height content=168 /><meta name=ROBOTS content="NOODP, NOYDIR, max-image-preview:large"/><meta name=google content=notranslate /><meta property=og:type content=article /><script>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</script><style>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</style><meta name=twitter:card content=summary_large_image /><meta name=twitter:image content="https://www.gannett-cdn.com/presto/2020/08/13/NDES/94f13d98-9aee-4f68-84be-667c04ad6977-log_com_calendar.jpg?crop=297,168,x0,y0&width=297&height=148&format=pjpg&auto=webp"/><meta name=twitter:site content=@waltonsun /><meta name=twitter:creator content=@waltonsun /><meta name=twitter:title content="DESTIN EVENTS AND ENTERTAINMENT March 20"/><meta name=twitter:description content="DESTIN EVENTS AND ENTERTAINMENT March 20"/></head><body><svg style=display:none><symbol id=gnt_svg_external viewBox="0 0 18 18"><path d="M12.43 5.5H10.5V4H15v4.5h-1.5V6.55l-4.56 4.56-1.06-1.06 4.55-4.55zm1.07 9v-3.75H15V16H3V4h5.25v1.5H4.5v9h9z"/></symbol><svg id=gnt_svg_share_facebook viewBox="0 0 24 24" style=fill:var(--gnt-sfc,#4460a0)><path d="M10.5932 20.9998C6.291 20.3204 3 16.5743 3 12.055 3 7.054 7.0294 3 12 3s9 4.054 9 9.0549c0 4.5198-3.2914 8.266-7.5943 8.9451v-6.3188h2.097l.3991-2.6175h-2.496v-1.6985c0-.716.3486-1.414 1.4666-1.414h1.1349V6.7227s-1.03-.1769-2.0146-.1769c-2.0558 0-3.3995 1.2536-3.3995 3.523v1.9948H8.3081v2.6175h2.2851v6.3186z"/></svg><symbol id=gnt_svg_share_twitter viewBox="0 0 24 24" style=fill:var(--gnt-sfc,#00aaec)><path d="M21 6.776a7.213 7.213 0 0 1-2.12.596 3.778 3.778 0 0 0 1.623-2.095 7.273 7.273 0 0 1-2.346.918A3.642 3.642 0 0 0 15.462 5c-2.038 0-3.692 1.696-3.692 3.787 0 .296.032.585.095.862-3.069-.158-5.79-1.664-7.612-3.958a3.856 3.856 0 0 0-.5 1.906c0 1.313.652 2.472 1.643 3.152a3.626 3.626 0 0 1-1.673-.473v.047c0 1.835 1.273 3.366 2.963 3.713-.31.089-.636.133-.973.133-.238 0-.47-.023-.695-.067.47 1.504 1.833 2.599 3.45 2.628A7.292 7.292 0 0 1 3 18.3 10.282 10.282 0 0 0 8.66 20c6.794 0 10.508-5.77 10.508-10.774 0-.164-.003-.329-.01-.49A7.58 7.58 0 0 0 21 6.776"/></symbol><symbol id=gnt_svg_share_email viewBox="0 0 24 24" style=fill:var(--gnt-sfc,#626262)><path d="M3 5.88c0-.49.4-.88.9-.88h16.2c.5 0 .9.4.9.88v12.24c0 .49-.4.88-.9.88H3.9a.9.9 0 0 1-.9-.88V5.88zm9 5.21L3 6.74v1.74l9 4.35 9-4.35V6.74l-9 4.35z"/></symbol><symbol id=gnt_svg_shareapi viewBox="0 0 24 24" style=fill:var(--gnt-sfc,#000)><path d="M14 5l6 7-6 7V5zm0 4v6c-1.937-.271-3.937.062-6 1s-3.73 2.271-5 4c.909-3.576 2.242-6.242 4-8s4.091-2.758 7-3z"/></symbol></svg><header class=gnt_n onmousedown=event.stopPropagation() onmouseup=event.stopPropagation()><div class=gnt_n_lg_w><button class=gnt_n_sb data-g-r=base_sb data-t-l=":n|v|c|skip to main content" aria-label="Skip to main content"></button><a class=gnt_n_lg href=/ aria-label="Walton Sun" data-t-l=:n|v|c|logo><svg class=gnt_n_lg_svg id=gnt_svg_lg fill=#DC352B preserveAspectRatio="xMinYMid meet" viewBox="0 0 341.97 28.63"><path d="M14.76 24.17c-.08 2.38.54 3.08 2.79 3.21h1.21v.83H4.63v-.83h1.25c2.21-.12 2.83-.83 2.75-3.21V1.92H6.79c-3.33-.13-5.38 2-5.59 5.84H0V.42h23.42v7.34h-1.21C22 3.88 19.96 1.8 16.58 1.92h-1.83v22.25zm20.17 0c-.08 2.38.54 3.08 2.79 3.21h.79v.83H25.26v-.83h.79c2.21-.12 2.83-.83 2.75-3.21V4.58c.08-2.46-.54-3.21-2.75-3.33h-.79V.42h13.25v.83h-.79c-2.25.13-2.88.88-2.79 3.33v8.63h10.84V4.58c.08-2.46-.58-3.21-2.79-3.33h-.79V.42h13.25v.83h-.79c-2.21.13-2.83.88-2.75 3.33v19.59c-.08 2.38.54 3.08 2.75 3.21h.79v.83H42.18v-.83h.79c2.25-.12 2.88-.83 2.79-3.21v-9.29H34.93v9.29zm31.34-.45c-.08 2.21.54 2.96 2.46 2.96h1.54c4.96.04 7.96-2.29 8.88-7h1.08l-1.38 8.54H56.6v-.83h.75c2.25-.12 2.88-.83 2.79-3.21V4.5c.08-2.38-.54-3.13-2.79-3.21h-.75V.42h21.76v7.67h-.92c-.42-3.96-2.63-6.09-6.38-6.21h-4.79v11.38h1.13c2.5-.08 3.88-2.04 4.25-6h1V20.8h-1v-.33c0-1.04-.12-1.79-.5-2.71-.88-2.08-1.96-2.92-3.75-2.92h-1.13v8.88zm38.38 4.83h-.71L95.9 5.96c-1.29-3.58-2.08-4.75-3.25-4.71V.42h10.59v.83h-.67c-.92 0-1.54.5-1.54 1.25 0 .58.04.75.75 2.67l5.04 13.96 4.08-10.46-1.21-3.5c-1.04-2.96-1.88-3.88-3.58-3.92h-.46V.42h12.34v.83h-.63c-1.42 0-2.08.46-2.08 1.42 0 .58.13 1.04.92 3.29l4.25 12.38 4.42-12.38c.29-.92.63-2.54.63-3.25 0-.83-.79-1.46-1.88-1.46h-.54V.42h6.29v.83c-1.33.21-1.75.92-3.54 5.92l-7.34 21.38h-.79l-6.09-17.76-6.96 17.76zm24.18-9.25l-1.58 4.46a7.21 7.21 0 00-.46 1.83c0 1 1.17 1.79 2.58 1.79h.92v.83h-8.75v-.83c1.63-.08 2.88-1.46 3.79-4.21L133.92.16h1.17l10.8 25.34c.67 1.5.96 1.79 1.96 1.88h.38v.83h-12.67v-.83h1.04c1.83 0 2.58-.46 2.58-1.54 0-.42-.13-.83-.54-1.75l-2.04-4.79h-7.77zm.58-1.54H136l-3.54-8.46-3.05 8.46zm40.97 10.46h-22.13v-.83h.79c2.21-.12 2.83-.83 2.75-3.21V4.5c.08-2.42-.54-3.13-2.75-3.25h-.79V.42h13.34v.83h-.92c-2.21.13-2.83.83-2.75 3.25v19.09c-.08 2.42.38 3.04 2.21 3h2.21c4.38.17 7-2.67 8.29-8.84h.83l-1.08 10.47zm14.8-4.05c-.08 2.38.54 3.08 2.79 3.21h1.21v.83h-14.13v-.83h1.25c2.21-.12 2.83-.83 2.75-3.21V1.92h-1.83c-3.33-.13-5.38 2-5.59 5.84h-1.21V.42h23.42v7.34h-1.21c-.21-3.88-2.25-5.96-5.63-5.84h-1.83v22.25zm33.71-20.13c2.63 2.71 3.83 5.96 3.83 10.42 0 8.38-5.71 14.17-13.92 14.17-8.5 0-14.09-5.71-14.09-14.34 0-4.71 1.54-8.34 4.67-11A13.3 13.3 0 01208.6 0c4.33 0 7.63 1.29 10.29 4.04zm-14.42-.46c-1.96 2.42-2.79 5.67-2.79 10.84 0 4.42.58 7.38 1.92 9.67a5.82 5.82 0 005 3.08 5.97 5.97 0 004.92-2.83c1.5-2.42 2.25-5.92 2.25-10.3 0-8.09-2.5-12.59-7.04-12.59a5.4 5.4 0 00-4.26 2.13zm23.34 20.59c-.08 2.38.54 3.08 2.79 3.21h.75v.83h-8.59v-.83h.79c2.21-.12 2.83-.83 2.75-3.21V3.83l-.92-1.08c-1.04-1.17-1.54-1.46-2.63-1.5V.42h8.67l14.67 17.88V4.54c.08-2.42-.54-3.17-2.79-3.29h-.75V.42h8.42v.83h-.71c-2.17.13-2.75.83-2.67 3.29v23.67h-.83L227.81 5.34v18.83zm54.64-15.38h-.96c-.38-2-.92-3.21-2.13-4.46a8.48 8.48 0 00-6.34-2.79c-3.13 0-5.25 1.63-5.25 4a3.8 3.8 0 001.96 3.25c.88.54.88.54 4.75 2 5.21 1.88 5.21 1.88 6.79 3.29a8.11 8.11 0 012.63 6.17c0 2.54-1 4.75-2.83 6.13a12.05 12.05 0 01-7.09 2.25c-1.83 0-3.71-.42-6.04-1.33a4.38 4.38 0 00-1.67-.42c-.92 0-1.42.46-1.75 1.63h-1.08v-10h1.08c.04 1.96.79 3.58 2.42 5.46 1.58 1.83 4.29 2.96 7.09 2.96 3.21 0 5.42-1.75 5.42-4.38a4.3 4.3 0 00-2.17-3.71c-.92-.58-.92-.58-4.96-2.13-4.63-1.75-4.71-1.79-6.04-2.88a7.62 7.62 0 01-2.71-5.96c0-4.58 3.79-7.88 9-7.88 2.04 0 3.38.33 6.79 1.63.21.08.5.12.79.12.88 0 1.29-.54 1.33-1.67h.96v8.72zm2.04-8.37H298v.83h-.75c-2.25.13-2.88.88-2.79 3.29v15.01c0 2.54.29 3.83 1.13 5 1 1.46 2.71 2.17 5.04 2.17 2.42 0 4.46-.83 5.67-2.38 1.25-1.58 1.67-3.33 1.67-7.04V5.17c.21-2.67-.92-3.92-3.46-3.92V.42h8.71v.83c-2.54-.04-3.71 1.21-3.63 3.92v13.05c0 3.63-.79 6-2.58 7.75-1.88 1.79-4.42 2.67-7.92 2.67-3.54 0-6.21-.83-8.17-2.5-1.83-1.58-2.58-3.46-2.58-6.59V4.54c.08-2.42-.54-3.17-2.79-3.29h-1.04V.42zm34.3 23.75c-.08 2.38.54 3.08 2.79 3.21h.75v.83h-8.59v-.83h.79c2.21-.12 2.83-.83 2.75-3.21V3.83l-.92-1.08c-1.04-1.17-1.54-1.46-2.63-1.5V.42h8.67l14.67 17.88V4.54c.08-2.42-.54-3.17-2.79-3.29h-.75V.42h8.42v.83h-.71c-2.17.13-2.75.83-2.67 3.29v23.67h-.83L318.79 5.34v18.83z"/></svg></a></div><div class="gnt_n_sm gnt_n_sm__ne gnt_n_nc__hbn"><a class="gnt_n_sm_a gnt_n_sm__ne_a" data-u-sr="anon reg" href="https://subscribe.waltonsun.com/specialoffer?gps-source=CPTILELEFT&itm_campaign=2021SPRING&itm_medium=ONSITE&onSuccessRedirectURL=https%3A%2F%2Fwww.waltonsun.com%2Fstory%2Fentertainment%2F2021%2F03%2F18%2Fdestin-events-and-entertainment-march-20%2F4747189001%2F" target=_blank rel=noopener data-t-l=":tiffany tile (left nanobar)|p|c|${n}SUBSCRIBE NOW" elementtiming=nav-submsg></a></div><div class="gnt_n_sm gnt_n_nc__hbn"><a class=gnt_n_sm_a data-u-sr="anon reg" href="https://subscribe.waltonsun.com/specialoffer?gps-source=CPMASTHEAD&itm_campaign=2021SPRING&itm_medium=ONSITE&onSuccessRedirectURL=https%3A%2F%2Fwww.waltonsun.com%2Fstory%2Fentertainment%2F2021%2F03%2F18%2Fdestin-events-and-entertainment-march-20%2F4747189001%2F" target=_blank rel=noopener data-t-l=":tiffany tile (right masthead)|p|c|SUBSCRIBE NOW" elementtiming=nav-submsg></a></div><nav class=gnt_n_mn aria-label="Global navigation"><a class="gnt_n_mn_l gnt_n_mn_l__fi gnt_n_mn_ce" href=/news/ data-t-l=:n|v|c|news elementtiming=nav-item>News</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=/sports/ data-t-l=:n|v|c|sports>Sports</a> <a class="gnt_n_mn_l gnt_n_mn_ce gnt_n_mn_l__se" href=/entertainment/ data-t-l=:n|v|c|entertainment>Entertainment</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=/lifestyle/ data-t-l=:n|v|c|lifestyle>Lifestyle</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=/opinion/ data-t-l=:n|v|c|opinion>Opinion</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=https://www.usatoday.com/ data-t-l=:n|v|c|nation-world>USA TODAY</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=http://obits.nwfdailynews.com/obituaries/nwfdailynews data-t-l=:n|v|c|obituaries>Obituaries</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=https://user.waltonsun.com/user/enewspaper data-t-l=:n|v|c|e-edition>E-Edition</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=https://floridapublicnotices.com/ data-t-l=:n|v|c|legals>Legals</a><div class=gnt_n_dd_w data-g-r="nav_ce nav_sh"><button class="gnt_n_dd_bt gnt_n_mn_ce" data-g-r=nav_ab data-g-tn=navgdp data-g-ltn=navgd data-t-l=:m|v|g|caret aria-label="Global Navigation" aria-haspopup=true aria-expanded=false><svg class=gnt_n_dd_bt_svg viewBox="0 0 10 6"><path d="M5 3.35L8.64 0 10 1.4 5 6 0 1.4 1.36 0z"/></svg></button></div><div class=gnt_n_us><div class=gnt_n_se data-g-r=nav_ce><a class="gnt_n_se_a gnt_n_mn_ce" data-g-r=nav_ab data-g-tn=navse href=/search/ data-t-l=:r|r|g|icon title=Search aria-label=Search aria-haspopup=true aria-expanded=false><svg class=gnt_n_se_a_svg viewBox="0 0 24 24"><path d="M15.75 14.33l4.96 4.96-1.42 1.42-4.96-4.96a6.5 6.5 0 1 1 1.41-1.41zM10.5 15a4.5 4.5 0 1 0 0-9 4.5 4.5 0 0 0 0 9z"/></svg></a></div><a class="gnt_n_wt gnt_n_mn_ce" href=/weather/ target=_blank rel="external noopener" aria-label="Weather in Santa Rosa Beach" title="Weather in Santa Rosa Beach" data-t-l=:n|v|c|weather></a> <a class=gnt_n_us_sb data-u-sr="anon reg" href="https://subscribe.waltonsun.com/specialoffer?gps-source=CPTOPNAVBAR&itm_campaign=2021SPRING&itm_medium=ONSITE&onSuccessRedirectURL=https%3A%2F%2Fwww.waltonsun.com%2Fstory%2Fentertainment%2F2021%2F03%2F18%2Fdestin-events-and-entertainment-march-20%2F4747189001%2F" target=_blank rel=noopener data-t-l=:n|p|c|subscribe elementtiming=nav-subbt>Subscribe</a></div></nav></header><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__hi"><div id=ad-slot-7103-fl-santarosabeach-C6736-high_impact-entertainment-1 class="gnt_x_sl gnt_x_hi"></div></aside><div class=gnt_bc></div><div class=gnt_cw_w><a class=gnt_cw_sl data-g-r=base_xbutton href=/entertainment/ data-t-l=|modalclose|overlay aria-label=Close aria-hidden=true tabindex=-1></a> <a class="gnt_cw_sl gnt_cw_sl__ed" data-g-r=base_xbutton href=/entertainment/ data-t-l=|modalclose|overlay aria-label=Close aria-hidden=true tabindex=-1></a><main class=gnt_cw><div class=gnt_ar_lbl aria-label=Entertainment data-c-ssts=ENTERTAINMENT></div><article class=gnt_pr><h1 class=gnt_ar_hl elementtiming=ar-headline>DESTIN EVENTS AND ENTERTAINMENT March 20</h1><div class=gnt_ar_by><a href=https://www.nwfdailynews.com/staff/5434366002/pam-griffin/ class="gnt_ar_by_a gnt_ar_by_a__fi">Pam Griffin</a><div class=gnt_ar_pb>The Destin Log</div></div><div class=gnt_ar_dt aria-label="Published 10:19 a.m. ET Mar. 18, 2021"></div><div class=gnt_ss data-g-r=base_sc data-ss-u=https://www.waltonsun.com/story/entertainment/2021/03/18/destin-events-and-entertainment-march-20/4747189001/ data-ss-t="DESTIN EVENTS AND ENTERTAINMENT March 20" data-ss-d="DESTIN EVENTS AND ENTERTAINMENT March 20"><a class=gnt_ss_a href="https://www.facebook.com/dialog/share?display=popup&app_id=596315637658855&href=https%3A%2F%2Fwww.waltonsun.com%2Fstory%2Fentertainment%2F2021%2F03%2F18%2Fdestin-events-and-entertainment-march-20%2F4747189001%2F" data-g-r=base_si data-ss-a=f data-t-l=${tc}|navbar-share-top|facebook aria-label="Share to Facebook" rel=noreferrer><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_facebook /></svg></a><a class=gnt_ss_a href="http://twitter.com/share?url=https%3A%2F%2Fwww.waltonsun.com%2Fstory%2Fentertainment%2F2021%2F03%2F18%2Fdestin-events-and-entertainment-march-20%2F4747189001%2F&text=DESTIN%20EVENTS%20AND%20ENTERTAINMENT%20March%2020&via=waltonsun" data-g-r=base_si data-ss-a=t data-t-l=${tc}|navbar-share-top|twitter aria-label="Share to Twitter" rel=noreferrer><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_twitter /></svg></a><a class=gnt_ss_a href="mailto:?subject=DESTIN%20EVENTS%20AND%20ENTERTAINMENT%20March%2020%20-%20from%20Walton%20Sun&body=DESTIN%20EVENTS%20AND%20ENTERTAINMENT%20March%2020%0A%0ADESTIN%20EVENTS%20AND%20ENTERTAINMENT%20March%2020%0A%0ACheck%20out%20this%20story%20on%20waltonsun.com%3A%20https%3A%2F%2Fwww.waltonsun.com%2Fstory%2Fentertainment%2F2021%2F03%2F18%2Fdestin-events-and-entertainment-march-20%2F4747189001%2F" data-t-l=${tc}|navbar-share-top|email aria-label="Share by email"><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_email /></svg></a><button class="gnt_ss_a gnt_ss_a__sa" data-g-r=base_si data-ss-a=s data-t-l=${tc}|navbar-share-top|shareapi aria-label="Share natively"><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_shareapi /></svg></button></div><aside class="gnt_em gnt_em_vp__tavp gnt_em__el" aria-label="Video - Sebastian Stan, Anthony Mackie talk Captain America's future"><div class="" data-g-r=vp_tp data-c-vt=teal data-t-pl=teal-automatedvideoplayer><div class="gnt_em_vp_a gnt_em_vp__tavp_a" data-g-r="vp_ap vp_tg" data-c-vpattrs="{&#34;muted&#34;:true,&#34;bContent&#34;:false,&#34;an&#34;:&#34;fl-santarosabeach-C6736&#34;,&#34;pn&#34;:&#34;Walton Sun&#34;,&#34;vidNum&#34;:1,&#34;avp&#34;:true}" data-c-vpdata="{&#34;adsEnabled&#34;:true,&#34;awsPath&#34;:&#34;entertainment&#34;,&#34;byline&#34;:&#34;Entertain This!&#34;,&#34;canonicalURL&#34;:&#34;&#34;,&#34;contentSourceCode&#34;:&#34;USAT&#34;,&#34;createDate&#34;:&#34;2021-03-19T14:16:10Z&#34;,&#34;credit&#34;:&#34;Entertain This!, USA TODAY&#34;,&#34;duration&#34;:85000,&#34;headline&#34;:&#34;Sebastian Stan and Anthony Mackie talk new miniseries, future for Captain America movies&#34;,&#34;hlsURL&#34;:&#34;https://hlsmedia.gannett-cdn.com/authoring/video-renditions/0ae2c019-f819-432e-9495-d20fa328350e/612bab3c-e99c-463e-a094-7591d0c1c6a9/1080p_30fps,720p_30fps,480p_30fps,master.m3u8?subtitles=4740330001&#34;,&#34;id&#34;:&#34;4740330001&#34;,&#34;image&#34;:{&#34;url&#34;:&#34;https://www.gannett-cdn.com/presto/2021/03/17/USAT/4596ea02-4ff9-4574-93da-a4f74ddbc9c9-20210319_368_FALCON_FINAL.jpg&#34;,&#34;opto&#34;:true},&#34;initialPublishDate&#34;:&#34;2021-03-19T14:16:10Z&#34;,&#34;keywords&#34;:&#34;Entertain This!,Video Syndication - OTT Platforms,Video Syndication - USAT,Overall Neutral,Sebastian Stan,Anthony Mackie,Movies,Marvel Entertainment,Walt Disney Company,Captain America: Civil War&#34;,&#34;mp4URL&#34;:&#34;https://downloadmedia.gannett-cdn.com/authoring/video-renditions/0ae2c019-f819-432e-9495-d20fa328350e/612bab3c-e99c-463e-a094-7591d0c1c6a9/1080p_30fps.mp4&#34;,&#34;origin&#34;:&#34;USA TODAY&#34;,&#34;pageURL&#34;:{&#34;long&#34;:&#34;https://www.usatoday.com/videos/entertainment/entertainthis/2021/03/19/sebastian-stan-anthony-mackie-talk-captain-americas-future-falcon-winter-soldier-interview/4740330001/&#34;},&#34;promoBrief&#34;:&#34;Anthony Mackie and Sebastian Stan chat with USA TODAY's Brian Truitt about the new Marvel miniseries, \&#34;The Falcon and the Winter Soldier,\&#34; on Disney+.&#34;,&#34;propertyName&#34;:&#34;USATODAY&#34;,&#34;publishDate&#34;:&#34;2021-03-19T14:35:59Z&#34;,&#34;series&#34;:&#34;&#34;,&#34;ssts&#34;:{&#34;section&#34;:&#34;entertainment&#34;,&#34;subsection&#34;:&#34;entertainthis&#34;,&#34;topic&#34;:&#34;&#34;,&#34;subtopic&#34;:&#34;&#34;},&#34;tags&#34;:[{&#34;id&#34;:&#34;f0b69399-5e0d-49f5-bb4d-d8d060dd4167&#34;,&#34;name&#34;:&#34;Entertain This!&#34;},{&#34;id&#34;:&#34;16fe9f9b-4247-4e2e-a73c-9fac5b14d01b&#34;,&#34;name&#34;:&#34;Video Syndication - OTT Platforms&#34;},{&#34;id&#34;:&#34;6f55135f-3b5e-490d-8a52-a3b8e1f11ee7&#34;,&#34;name&#34;:&#34;Video Syndication - USAT&#34;},{&#34;id&#34;:&#34;b1f98bf0-fec4-4355-b249-83c774dfa894&#34;,&#34;name&#34;:&#34;Overall Neutral&#34;},{&#34;id&#34;:&#34;79379e06-0904-40a6-b0e8-0451e2e5a77f&#34;,&#34;name&#34;:&#34;Sebastian Stan&#34;},{&#34;id&#34;:&#34;c18ce0d7-3f4b-44f9-b6f0-cb94d72b2287&#34;,&#34;name&#34;:&#34;Anthony Mackie&#34;},{&#34;id&#34;:&#34;5db2c400-8d4d-49a7-8357-3d8982486d93&#34;,&#34;name&#34;:&#34;Movies&#34;},{&#34;id&#34;:&#34;35cacab8-7db4-49e9-bfcd-d474793d20d6&#34;,&#34;name&#34;:&#34;Marvel Entertainment&#34;},{&#34;id&#34;:&#34;b9e9698a-f3b3-41b3-aed1-ed9a2fadc861&#34;,&#34;name&#34;:&#34;Walt Disney Company&#34;},{&#34;id&#34;:&#34;152c52f9-c0a9-40f6-beb1-7be59c584bf7&#34;,&#34;name&#34;:&#34;Captain America: Civil War&#34;}],&#34;title&#34;:&#34;Sebastian Stan, Anthony Mackie talk Captain America's future&#34;,&#34;url&#34;:&#34;/videos/entertainment/entertainthis/2021/03/19/sebastian-stan-anthony-mackie-talk-captain-americas-future-falcon-winter-soldier-interview/4740330001/&#34;}"></div><button class=gnt_em_vp_db aria-label="Close autoplay video player" data-t-l=${tc}|tealplayer|automated-playerClose><svg viewBox="0 0 16 16"><path d="M9 7.625L13.125 3.5 14.5 4.875 10.375 9l4.125 4.125-1.375 1.375L9 10.375 4.875 14.5 3.5 13.125 7.625 9 3.5 4.875 4.875 3.5 9 7.625z"/></svg></button><div class=teal-video-wrap><video poster="https://www.gannett-cdn.com/presto/2021/03/17/USAT/4596ea02-4ff9-4574-93da-a4f74ddbc9c9-20210319_368_FALCON_FINAL.jpg?width=660&height=371&fit=crop&format=pjpg&auto=webp" title="Sebastian Stan, Anthony Mackie talk Captain America's future" muted playsinline elementtiming=avp-video></video></div></div></aside><div class=gnt_ar_b><figure class="gnt_em gnt_em__fp gnt_em_img"><img class=gnt_em_img_i style=height:168px src="https://www.gannett-cdn.com/presto/2020/08/13/NDES/94f13d98-9aee-4f68-84be-667c04ad6977-log_com_calendar.jpg?width=299&height=168&fit=crop&format=pjpg&auto=webp" elementtiming=ar-lead-image decoding=async alt="Community events, entertainment"/><div class="gnt_em_img_ccw gnt_em_img_ccw__cap gnt_em_img_ccw__crd" data-c-caption="Community events, entertainment" data-c-credit="[CONTRIBUTED PHOTO]"></div></figure><p class=gnt_ar_b_p><em>Please send your events, meetings, etc., to pgriffin@thedestinlog.com at least 2 weeks in advance. </em></p><p class=gnt_ar_b_p>Destin City Hall</p><p class=gnt_ar_b_p>All city meetings are being held at the City Hall Annex, 4100 Indian Bayou Trail, until further notice. All meetings are subject to change or cancellation. To virtually view the meeting, https://www.cityofdestin.com/. To view/stream is www.youtube.com/CityofDestin.</p><p class=gnt_ar_b_p>Parks & Recreation,  4 p.m. March 23</p><p class=gnt_ar_b_p>Special Magistrate Hearing, 5:30 p.m. March 23</p><p class=gnt_ar_b_p>Harbor Capacity Steering Committee, 5:30 p.m. March 24</p><p class=gnt_ar_b_p>Silent Disco Party</p><p class=gnt_ar_b_p>Dance to your own beat with a silent disco experience in front of the main stage at HarborWalk Village from 7-10 p.m. every Wednesday through April 7. Sanitized headphones provided.</p><p class=gnt_ar_b_p>Stage Crafters</p><p class=gnt_ar_b_p>Stage Crafters Community Theatre, Inc. will present its first production of its 49th season, Baskerville: A Sherlock Holmes Mystery. Show dates are March 20-21. Friday and Saturday shows are at 7:30 p.m. and Sunday shows are at 2 p.m. at the Fort Walton Beach Civic Auditorium. COVID-19 precautions are in place including socially distanced seats, hand-sanitizer stations and the recommended use of masks. Purchase tickets at www.stagecraftersfwb.com.</p><p class=gnt_ar_b_p>Travel to Italy with Art</p><p class=gnt_ar_b_p>Escape to the beautiful and diverse country of Italy via Andi Scuto’s art sketch travel diary through March at the Destin Library. Her collection of 15 illustrations is currently displayed on the walls of the library.For more information, call 837-8572 or email library@cityofdestin.com.</p><p class=gnt_ar_b_p>Sunset Celebration</p><p class=gnt_ar_b_p>As the sun sets, stroll along the harbor in HarborWalk Village every Friday from 5-7 p.m. during spring break, through April 9. Enjoy local artists, live music and family-friendly activities.</p><p class=gnt_ar_b_p>Mermaids & Pirates</p><p class=gnt_ar_b_p>Ahoy Mateys! Seek hidden treasure and magic mermaids and be enchanted with a live performance by Captain Davy on the main stage at HarborWalk Village from 5-7 p.m. every Saturday March 20-April 10.</p><p class=gnt_ar_b_p>ECAR Barbeque Cook-Off</p><p class=gnt_ar_b_p>The Emerald Coast Association of Realtors Community & Military Outreach Committee is hosting a Barbecue Cook-Off from 11 a.m. to 1 p.m. March 20 at 3rd Planet Brewing Co., 1400 E John Sims Parkway in  Niceville. All proceeds benefit Elder Services of Okaloosa County. Attendees are invited to enter their barbecue or to vote on their favorites for an important cause.</p><p class=gnt_ar_b_p>Hollywood Murder Mystery Dinner Theatre </p><p class=gnt_ar_b_p>Hollywood Murder Mystery Dinner Theatre Show presents Lights, Camera, MURDER! At 7 p.m. March 20 at AJ’s on the Bayou. Doors open at 6:30 p.m. Purchase tickets for $55 at </p><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__al"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-fl-santarosabeach-C6736-native-article_link-entertainment-2 class="gnt_x_sl gnt_x_al"></div></aside><p class=gnt_ar_b_p>https://www.eventbrite.com/e/lights-camera-murder-murder-mystery-dinner-theatre-ajs-on-the-bayou-tickets-141743315071?aff=affiliate1.</p><p class=gnt_ar_b_p>You are on set with Max Moon’s film company, Insanity Pictures, and he is grossly over budget on his latest film: TOR-nado (The gripping story of scientifically engineered mutant tortoises that get sucked up into a freak hurricane off the coast of Milton, and then wreak havoc across the Midwest) When something goes terribly wrong on set it will be up to Detective Gunn and YOU to figure out, Who done it?</p><p class=gnt_ar_b_p>Vettes at the Village</p><p class=gnt_ar_b_p>Vroom, vroom Vettes at The Village of Baytowne Wharf returns from 10 a.m. to 4 p.m. March 20. Area corvette clubs bring "America's Sports Car" to the Events Plaza. Be a part of the show and vote for your favorite style and model. To register visit</p><p class=gnt_ar_b_p>www.playgroundcorvetteclub.com/events</p><p class=gnt_ar_b_p>Sunday Cinema</p><p class=gnt_ar_b_p>Grab a lawn chair or blanket and cozy up on the Events Plaza Lawn for the movie “Onward” at 7:15 p.m. March 21.</p><p class=gnt_ar_b_p>• March 28: Trolls World Tour</p><p class=gnt_ar_b_p>• April 4: </p><p class=gnt_ar_b_p>Wednesday Night Concert Series</p><p class=gnt_ar_b_p>Sit back and relax, and enjoy free live entertainment with  Forrest Williams Band from 7-9 p.m. March 24 on the Events Plaza stage at The Village of Baytowne Wharf.</p><p class=gnt_ar_b_p>• March 31: Will Thompson Band</p><p class=gnt_ar_b_p>• April 7: Nighttrain - The Guns & Roses Tribute Experience</p><p class=gnt_ar_b_p>• April 14: Highway to Hell - ACDC & Def Leppard Tribute</p><p class=gnt_ar_b_p>• April 21: Barracuda - America's Heart Tribute</p><p class=gnt_ar_b_p>• April 28: Emerald Coast Blues Brothers</p><p class=gnt_ar_b_p>Band of Revival</p><p class=gnt_ar_b_p>Mattie Kelly Arts Center in Niceville presents an evening of Americana music at the outdoor Amphitheater from 6-8 p.m.  March 25. Enjoy music from the Band of Revival and special guest, the NWFSC Jazz Ensemble. A food truck will be available on-site for food and beverage purchases. Bring your lawn chairs or blankets. Tickets are $10/adults. Kids 12 and under are free.</p><p class=gnt_ar_b_p>Listening Lounge</p><p class=gnt_ar_b_p>Emerald Coast Theatre Company (ECTC) will put a spring in your step and a song in your heart when singer/songwriter Daniel Pratt takes the stage in The Listening Lounge March 26 at 7:30 p.m. within ECTC’s performance space on the second floor of 560 Grand Boulevard in Grand Boulevard at Sandestin in Miramar Beach. Tickets are $22/adults; $2o/seniors/military; $18/students. Purchase tickets at www.emeraldcoasttheatre.org.</p><p class=gnt_ar_b_p>The Rainbow Fish</p><p class=gnt_ar_b_p>Sharing makes you shiny in this beautiful children’s classic by Marcus Pfister. Children will experience The Rainbow Fish through movement, song, color, and hands on sensory opportunities as they become part of the story with the actors at 9 a.m. March 26-27 and April 2-3 with the Emerald Coast Theatre Company at 560 Grand Blvd., upstairs, in Miramar Beach. Purchase tickets at www.emeraldcoasttheatre.org/on-stage.</p><p class=gnt_ar_b_p>GSOC</p><p class=gnt_ar_b_p>The Genealogical Society of Okaloosa County will host a free presentation by Janeen Bjork on “Create A Book, Honor Your Ancestor for Posterity” at 10:30 a.m. March 27 on Zoom. The public is invited. If you are not a registered GSOC member, send an email with your full name and email address to gsocokaloosa@gmail.com and a meeting link will be provided.</p><p class=gnt_ar_b_p>Crawfish Boil</p><p class=gnt_ar_b_p>An authentic New Orleans style Crawfish Boil will be held from 5-9 p.m. March 27 at 3rd Planet Brewery, 1400 E. John Sims Parkway in Niceville. Crawfish plates are $10. Enjoy live music with Duchess and games for the kids. Proceeds benefit the Northwest Florida Symphony Orchestra  and youth music programs.</p><p class=gnt_ar_b_p>Spring Forward Vendor Event</p><p class=gnt_ar_b_p>Start spring shopping early at the Spring Forward Vendor Event from 11 a.m. to 3 p.m. March 27 at American Legion Destin Post 296, 311 Main Street. American Legion members will be available to provide additional information about the organization and their recently upgraded event room. Relay for Life of the Emerald Coast will also be present to share how they are making this year’s relay a success. Vendors from all over the Panhandle will be ready to help you select that perfect new gift. Vendors interested in participating should contact Michelle Castro at shellecfl@gmail.com.</p><p class=gnt_ar_b_p>Embroiderers' Guild</p><p class=gnt_ar_b_p>The Sand Dunes Chapter of Embroiderers' Guild of America will meet from 1:30-4:30 p.m. March 29 in the Religious Education building, Holy Name of Jesus Catholic Church, 1200 Valparaiso Blvd, in Niceville. Visitors are welcome. Call 496-3466 with any questions.</p><p class=gnt_ar_b_p>Sew Spring Crafts</p><p class=gnt_ar_b_p>Celebrate spring and learn a useful skill with the Sew Springs Crafts Beanstack Challenge presented by the Destin Library. From March 29 to May 23, have fun learning basic sewing stitches while creating a new spring-themed craft each week. You can earn badges by completing the challenges or by reading sewing books and logging your reading minutes. Beanstack is available as a free app for your mobile device or through the web at www.cityofdestin.beanstack.org. If you need information, contact Sandee Kelly at 837-8572 or email skelly@cityofdestin.com.</p><p class=gnt_ar_b_p>Doggie EGGstravaganza</p><p class=gnt_ar_b_p>Dog-Harmony presents the sixth annual, canine-only Easter egg hunt and social, Doggie EGGstravaganza, from 5-7:30 p.m. April 1 at Grand Boulevard in Miramar Beach. The fundraising event is open to the public at no charge, but for those pups wanting to participate in the hunt, a donation of $10 is encouraged. Each participant will receive a souvenir bag filled with sponsor swag to collect eggs. People and puppy prizes will be hidden in colorful holiday eggs and scattered throughout the lawn. Designated areas for pets over 25 pounds and under will be available and all dogs must be leashed. Please no prong, choke or shock collars at the event.</p><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__al"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-fl-santarosabeach-C6736-native-article_link-entertainment-3 class="gnt_x_sl gnt_x_al"></div></aside><p class=gnt_ar_b_p>Guests will enjoy snacks courtesy of JC's Gourmet, beer and wine, family-friendly games and great prizes. Local musician Rob Romans "Sunsets, Songs, and Stories" will provide the entertainment and tunes. This event is presented as part of the Coastal Culture Series made possible by the Grand Boulevard Arts & Entertainment Program.</p><p class=gnt_ar_b_p>Dance Facets</p><p class=gnt_ar_b_p>An annual dance concert hosted by the Northwest Florida State College Department of Dance, Dance Facets presents an evening of dance at 7:30 p.m. April 2 and 3 on the mainstage at Mattie KellyFine and Performing Arts Center. Tickets are $15/adults and $10/youth ages 18 and under. Purchase tickets at 850-729-6000.</p><aside class="gnt_em gnt_em_anc" id=gnt_atomsnc data-g-r=lazy data-gl-method=loadAnc aria-label="Newsletter signup form"></aside><p class=gnt_ar_b_p>The production showcases many styles of dance — ballet, jazz, tap, and contemporary — and features choreography from students, faculty, and guest choreographers. This year's concert will also feature a special guest appearance by Pittman Magic, Juggling, and Comedy.</p><p class=gnt_ar_b_p>Destin Egg Hunt</p><p class=gnt_ar_b_p>The City of Destin will host its annual Easter Egg Hunt Drive-Thru on Saturday, April 3, at Morgan Sports Center, 4200 Indian Bayou (east parking lot), from 9-11 a.m. Staff will distribute treats, prizes, and Easter eggs for patrons to collect safely from the comfort of their vehicle.</p><p class=gnt_ar_b_p>Easter Explosion</p><p class=gnt_ar_b_p>Hop on over to the Village of Baytowne Wharf from 12-3 p.m. April 3 for a day filled with family-friendly entertainment, face-painting, arts and crafts and more. Also, don’t forget to get your picture taken with the Easter Bunny.</p><p class=gnt_ar_b_p>Grayt Easter Race</p><p class=gnt_ar_b_p>The 2021 Grayt Easter Race will take place at Grayton Beach State Park April 3. The event will offer three different courses to choose from: the CLEAN FEET 5K course, the DIRTY FEET 5K course and, brand new, the STINKY FEET 10K course. Start and finish lines will be adjacent to the pavilion at the end of Main Park Road within the park. Staggered start times from 7-9:15 a.m. will be used as a COVID-19 precautionary measure. Up to 30 runners will start each wave. The awards ceremony begins at 10 a.m. and all registered runners will receive a race shirt. The race benefits Communities of Transformation of South Walton.</p><p class=gnt_ar_b_p>Lulu’s Easter, New Arcade</p><p class=gnt_ar_b_p>Bring the family and hop on over to LuLu’s on April 3 and 4 to check out the grand opening of the video Arcade and see the tropically clad Easter Bunny. He will be on hand for free socially distanced photo ops with the kids both days from 11 a.m. to 2 p.m. The Easter Bunny will be visiting with boys and girls and giving them Easter gift bags with candy, crafts and plastic eggs. Four lucky children will find “Golden Eggs” in their gift bags with a $100 Arcade play card.</p><p class=gnt_ar_b_p>Beer-ster Egg Hunt</p><p class=gnt_ar_b_p>The annual adult Easter egg hunt at Idyll Hounds in Santa Rosa Beach is back April 4 at Idyll Hounds. The brewery hides various canned beers and eggs with prizes around the outdoor space for adults to hunt with “6-pack Easter baskets.” The event is ticketed and includes the found 6-pack of beer and whatever hidden brewery goodies the participants find.</p><p class=gnt_ar_b_p>NFSO</p><p class=gnt_ar_b_p>Led by NFSO conductor search finalist Glen Cortese, the orchestra will take you on a journey of musical twists and turns at 7:30 p.m. April 10 with pieces based on variations featuring Leonard Bernstein’s Three Dance Variations from “Fancy Free,” the ever-popular Rhapsody on a Theme of Paganini by Rachmaninoff featuring New York pianist Philip Edward Fisher, and Brahms’ Symphony No. 4 in E minor. Tickets are $25/adults and $16/students of NWFSC. Virtual tickets are also available for live streaming at www.virtualticketcenter.com.</p><p class=gnt_ar_b_p>Gospel Brunch</p><p class=gnt_ar_b_p>Sinfonia Gulf Coast will hold a Gospel Brunch featuring D’Vine at 10:30 a.m. April 11</p><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__al"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-fl-santarosabeach-C6736-native-article_link-entertainment-4 class="gnt_x_sl gnt_x_al"></div></aside><p class=gnt_ar_b_p>(rescheduled from December) at Hotel Effie Sandestin, 1 Grand Sandestin Boulevard in Miramar Beach. Tickets are $95 - $125 (all inclusive) and include performance, brunch and all gratuities. Bloody Mary, Mimosa and cash bars will be available. Tickets available at http://bit.ly/GospelBrunch21.</p><p class=gnt_ar_b_p>Food For Thought Dinner</p><p class=gnt_ar_b_p>Don't miss out on the Annual Food For Thought Full Circle Dinner April 12 at Seagar's Prime Steaks and Seafood in the Hilton Sandestin. Cocktails begin at 5 p.m. with dinner at 6 p.m. Cocktail/Resort Casual Attire. Registration closes March 30. Reserve your table at //ow.ly/jANq50Dylga.</p><p class=gnt_ar_b_p>MKAF Arts Guild Lunch</p><p class=gnt_ar_b_p>With the help of a little magic, the popular Mattie Kelly Arts Foundation Arts Guild Lunch titled "Hocus Focus: Spotlight on Arts Education" returns on April 14. Hosted at the new Hotel Effie from 11:30 a.m.  to 1 p.m., the Arts Guild Lunch features master magician and illusionist, Kevin Spencer. Proceeds from all MKAF events benefit the organization and its outreach and community engagement initiatives throughout Northwest Florida. Tickets are available on Eventbrite. Tickets are $45 per person for MKAF Members and $55 per person for non-members.</p><p class=gnt_ar_b_p>Yard Sale</p><p class=gnt_ar_b_p>A Community Yard Sale will be held in the parking lot of Immanuel Anglican Church, 250 Indian Bayou Trail, in Destin, from 8 a.m. to 1 p.m. April 17  in conjunction with the second Immanuel Art & Music Fest. Art vendors will also be set up and a variety of musical groups will perform. Bayou Breaux’s Food Truck will be on site for purchase. Free funnel cakes.</p><p class=gnt_ar_b_p>Spring Break Camp</p><p class=gnt_ar_b_p>The Destin Community Center will offer a “Spring into Fun” Camp 9 a.m. to 5 p.m. April 19 through April 23. Camp registration is open to residents of Okaloosa County between the ages of 5 – 12. Space is limited and pre-registration is required. Cost is $80/residents and $90/non-residents within Okaloosa County. Counselors and campers will have their temperatures taken upon arrival and will adhere to the Center of Disease Control (CDC) guiding principles. Call 654-5184 or email Recreation@cityofdestin.com for information.</p><p class=gnt_ar_b_p>Seabreeze Jazz Festival</p><p class=gnt_ar_b_p>Tickets are on sale at www.seabreezejazzfestival.com for the 2021 Seabreeze Jazz Festival April 21-25. Or charge by phone at 855-233-6714.</p><p class=gnt_ar_b_p>Concerts in the Village</p><p class=gnt_ar_b_p>Kick off the season at 7 p.m. April 22 with a collaborative and creative event</p><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__al"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-fl-santarosabeach-C6736-native-article_link-entertainment-5 class="gnt_x_sl gnt_x_al"></div></aside><p class=gnt_ar_b_p>Presented by MKAF and performed by Sinfonia Gulf Coast, the non-profit duo brings “The Music of Queen” with Conductor Brent Havens and Vocalist Brody Dolyniuk to the Dugas Stage. Admission is $25/adults, $15/active-duty military, and children (12 and under) and MKAF members are free. Purchase tickets online at Eventbrite. Gates open 6 p.m. Admission for the remaining concerts is $15/adults, $10/active-duty military, and children (12 and under) and MKAF members are free.</p><p class=gnt_ar_b_p>• April 29: Duchess</p><p class=gnt_ar_b_p>• May 6: Shania Twin, Shania Twain Tribute</p><p class=gnt_ar_b_p>• May 13: M80s</p><p class=gnt_ar_b_p>• May 20: A Brother' Revival, an Allman Brother Tribute</p><p class=gnt_ar_b_p>• May 27: Deana Carter</p><p class=gnt_ar_b_p>• June 3: The Tams</p><p class=gnt_ar_b_p>• June 10: Kara Grainger</p><p class=gnt_ar_b_p>• June 17: Petty Hearts, Tom Petty Tribute</p><p class=gnt_ar_b_p>• June 24: Air National Guard Band of the South</p><p class=gnt_ar_b_p>Lionfish Festival</p><p class=gnt_ar_b_p>The Florida Fish and Wildlife Conservation Commission (FWC) has announced the seventh annual Lionfish Removal and Awareness Festival is scheduled for May 15 and 16 at AJ’s Seafood and Oyster Bar and HarborWalk Village in Destin. Come out and celebrate the fight against invasive lionfish with the FWC and Destin–Fort Walton Beach. Activities will include fillet demonstrations; family-friendly games and activities; art, diving and conservation booths; and the world’s largest lionfish spearfishing tournament, the Emerald Coast Open. Satisfy your taste buds by visiting any of the participating locations of Lionfish Restaurant Week May 10-14 for your chance to try this delicious invasive.</p><p class=gnt_ar_b_p>Smoke on the Coast</p><p class=gnt_ar_b_p>Destin Commons will host 15 local non-profit organizations at the 10th annual Smoke on the Coast BBQ & Fireworks Festival from 5-10 p. m. July 3. Each non-profit organization teams up with a restaurant or BBQ aficionado. Cast your vote for $1 for your favorite BBQ team, support their mission, and enjoy a day of family fun.</p><p class=gnt_ar_b_p>Destin Woman's Club</p><p class=gnt_ar_b_p>The Annual Fashion Show held by the Destin Woman's Club has been cancelled this year due to the Covid virus. The Fashion Show for 2021 has been scheduled for Nov. 5.  As their major fundraiser, net proceeds go toward the Club's Family Assistance Fund designed to help local families and a local charity.</p><p class=gnt_ar_b_p>RECURRING EVENTS</p><p class=gnt_ar_b_p>Destin Community Center</p><p class=gnt_ar_b_p>All activities are at the Destin Community Center, unless noted. Call 654-5184 or email recreation@cityofdestin.comfor information and to register. Persons with disabilities who require assistance are asked to notify the center 48 hours in advance.</p><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__al"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-fl-santarosabeach-C6736-native-article_link-entertainment-6 class="gnt_x_sl gnt_x_al"></div></aside><p class=gnt_ar_b_p>Pickleball: Sessions are Mondays from 12:30-3:30 p.m. Wednesdays from 1-2 p.m. and Fridays from 10:30 a.m. until 1:30 p.m. Fee is $3/session. Racquets and balls are available, just bring your gym shoes.</p><p class=gnt_ar_b_p>Table Tennis: Play from 10 a.m. to 1 p.m. Mondays, Wednesdays and Fridays. Paddles and balls provided. Fee is $2/resident and $3/non-resident.</p><p class=gnt_ar_b_p>Senior Programs</p><p class=gnt_ar_b_p>All activities are at the Destin Community Center, unless noted. Call 654-5184 or email recreation@cityofdestin.com for information and to register. Persons with disabilities who require assistance are asked to notify the center 48 hours in advance. </p><p class=gnt_ar_b_p>— Destin Senior Membership: Join the Destin Seniors to enjoy multiple festivities including the senior lunch bunch, potluck, casino trips, cruises, bingo, chair exercise, knitting, scrabble, and Mexican dominoes. Members must be a Destin resident.</p><p class=gnt_ar_b_p>— Senior Book Club: The Destin Senior Members meet at 10 a.m. the 2nd Wednesday of the month at the Destin Library, 150 Sibert Ave.</p><p class=gnt_ar_b_p>— Senior Drop-In Hours: The Destin Senior Center at Buck Destin Park, 724 Legion Drive, offers senior drop-in hours from 9 a.m. to noon every Tuesday and Thursday for Seniors (50 years and older) to meet and enjoy each other’s company, participate in games such as Mexican Train Dominoes, Scrabble, cards, etc.</p><p class=gnt_ar_b_p>— Senior Walking Club: The Destin Senior Members walk around the Destin Community Center’s gymnasium from 8-9 a.m. Monday-Friday. All of the miles that you walk will be added to the “team map” as we travel from one region to the next. The team’s miles are reported on the 4th Friday of each month at the Destin Senior Membership’s Potluck.</p><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__al"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-fl-santarosabeach-C6736-native-article_link-entertainment-7 class="gnt_x_sl gnt_x_al"></div></aside><p class=gnt_ar_b_p>— Destin Senior Chair Exercise 50+ years: Monday and Wednesday mornings from 10-10:45 a.m. at Buck Destin Park consists of performing light exercises to help improve balance, flexibility, strength, and circulation. Free/residents.</p><p class=gnt_ar_b_p>Book Club</p><p class=gnt_ar_b_p>The Destin Library’s Novel Idea Book Club is open to adults and meets every fourth Thursday of the month at 11:30 a.m. via Microsoft Teams. Club members can submit book recommendations – primarily fiction with the occasional non-fiction title – and the club will vote on which ones to read. Membership is open to everyone; however, you will need an Okaloosa County Public Library card to check-out materials. Members will need an email address and internet access to join the discussion.</p><p class=gnt_ar_b_p>City of Destin Annual Passes</p><p class=gnt_ar_b_p>Full-time residents (within the incorporated city limits) are encouraged to submit their request for a 2021 Annual Pass at https://www.cityofdestin.com/342/Annual-Passes. For those who do not have internet access, beach parking passes are only available at City Hall. Henderson Beach State Park and Joe’s Bayou Boat Ramp passes are available at both City Hall and the Destin Community Center. For questions, call 837-4242.</p><p class=gnt_ar_b_p>Adopt-A-Street</p><p class=gnt_ar_b_p>The City of Destin’s Adopt-A-Street Program allows local families, businesses and community groups to perform a valuable community service by adopting sections of a street to keep clear of litter and debris. Groups who participate in this program will have their name listed on the City’s website and signage installed on their adopted street. For more information, call 837-6869 or email adoptastreet@cityofdestin.com.</p><p class=gnt_ar_b_p>Grand Boulevard Farmers Market</p><p class=gnt_ar_b_p>Grand Boulevard Farmers Market takes place every Friday and Saturday from 9 a.m. to 1 p.m. at Grand Park in the heart of Grand Boulevard in South Walton. Bring your shopping bag and load up on local produce, eggs, jams and pies. Homemade soap, good olive oil, and pickled things are all there for the taking. </p><p class=gnt_ar_b_p>Rosemary Beach Farmers Market</p><p class=gnt_ar_b_p>Come browse the 30A Farmers Market in Rosemary Beach on Sundays from 9 a.m. to 1 p.m. The local farmers market takes place on Sundays year round, and Thursdays throughout the summer months, in North Barrett Square along Scenic 30A.</p></div><div class=gnt_ss data-g-r=base_sc data-ss-u=https://www.waltonsun.com/story/entertainment/2021/03/18/destin-events-and-entertainment-march-20/4747189001/ data-ss-t="DESTIN EVENTS AND ENTERTAINMENT March 20" data-ss-d="DESTIN EVENTS AND ENTERTAINMENT March 20"><a class=gnt_ss_a href="https://www.facebook.com/dialog/share?display=popup&app_id=596315637658855&href=https%3A%2F%2Fwww.waltonsun.com%2Fstory%2Fentertainment%2F2021%2F03%2F18%2Fdestin-events-and-entertainment-march-20%2F4747189001%2F" data-g-r=base_si data-ss-a=f data-t-l=${tc}|navbar-share-bottom|facebook aria-label="Share to Facebook" rel=noreferrer><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_facebook /></svg></a><a class=gnt_ss_a href="http://twitter.com/share?url=https%3A%2F%2Fwww.waltonsun.com%2Fstory%2Fentertainment%2F2021%2F03%2F18%2Fdestin-events-and-entertainment-march-20%2F4747189001%2F&text=DESTIN%20EVENTS%20AND%20ENTERTAINMENT%20March%2020&via=waltonsun" data-g-r=base_si data-ss-a=t data-t-l=${tc}|navbar-share-bottom|twitter aria-label="Share to Twitter" rel=noreferrer><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_twitter /></svg></a><a class=gnt_ss_a href="mailto:?subject=DESTIN%20EVENTS%20AND%20ENTERTAINMENT%20March%2020%20-%20from%20Walton%20Sun&body=DESTIN%20EVENTS%20AND%20ENTERTAINMENT%20March%2020%0A%0ADESTIN%20EVENTS%20AND%20ENTERTAINMENT%20March%2020%0A%0ACheck%20out%20this%20story%20on%20waltonsun.com%3A%20https%3A%2F%2Fwww.waltonsun.com%2Fstory%2Fentertainment%2F2021%2F03%2F18%2Fdestin-events-and-entertainment-march-20%2F4747189001%2F" data-t-l=${tc}|navbar-share-bottom|email aria-label="Share by email"><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_email /></svg></a><button class="gnt_ss_a gnt_ss_a__sa" data-g-r=base_si data-ss-a=s data-t-l=${tc}|navbar-share-bottom|shareapi aria-label="Share natively"><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_shareapi /></svg></button></div><div class="gnt_tb gnt_tbb"><div id=gnt_tbw_1></div></div></article><div class=gnt_rr><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__pf"><div id=ad-slot-7103-fl-santarosabeach-C6736-poster-entertainment-8 class="gnt_x_sl gnt_x_p"></div></aside><div class="gnt_tb gnt_tbr" data-t-l=${tc}|rightRailTaboolaRecirc|click><div id=gnt_tbw_2></div></div><div class="gnt_m gnt_m_fs"><a href="https://cm.waltonsun.com/site-feedback/?platform=Tangent-Desktop&url=https%3A%2F%2Fwww.waltonsun.com%2Fstory%2Fentertainment%2F2021%2F03%2F18%2Fdestin-events-and-entertainment-march-20%2F4747189001%2F&marketName=waltonsun&cta=Right-Rail" class=gnt_m_fs_a data-t-l=${tc}survey_click_story aria-label="Notice our new look? As you get used to things, please let us know what you think!"></a></div><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__st"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-fl-santarosabeach-C6736-poster_scroll-entertainment-9 class="gnt_x_sl gnt_x_sl__st gnt_x_p"></div></aside></div><div class=gnt_xbr><a class=gnt_ar_xb data-g-r=base_xbutton href=/entertainment/ data-t-l=|modalclose|x aria-label=Close></a></div></main></div><footer class=gnt_ft data-g-r="lazy lazy_p" data-gl-type=method data-gl-method=shbd><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__lb"><div id=ad-slot-7103-fl-santarosabeach-C6736-leaderboard_btf-entertainment-10 class=gnt_x_lb></div></aside><svg class="gnt_ft_lg gnt__hbd" data-g-r=lazy_c alt="Walton Sun - Part of the USA Today Network"><use xlink:href=#gnt_svg_lg alt/></svg><div class="gnt_ft_lw gnt__hbd" data-g-r=lazy_c><div class=gnt_ft_ls aria-label=About><a href=http://www.gannett.com/careers/ class=gnt_ft_a data-t-l=:f|v|c|about:careers>Careers</a> <a href=https://cm.waltonsun.com/accessibility/ class=gnt_ft_a data-t-l=:f|v|c|about:accessibility>Accessibility</a> <a href=https://www.waltonsun.com/sitemap/ class=gnt_ft_a data-t-l=:f|v|c|about:site-map>Site Map</a> <a href=https://floridapublicnotices.com/ class=gnt_ft_a data-t-l=:f|v|c|about:legals>Legals</a> <a href=https://cm.waltonsun.com/ethical-conduct/ class=gnt_ft_a data-t-l=:f|v|c|about:our-ethical-principles>Our Ethical Principles</a> <a href=https://cm.waltonsun.com/terms/ class=gnt_ft_a data-t-l=:f|v|c|about:terms-of-service>Terms of Service</a> <a href=https://cm.waltonsun.com/privacy/ class=gnt_ft_a data-t-l=:f|v|c|about:privacy-policy>Privacy Policy</a> <a href=https://cm.waltonsun.com/privacy-policy/ class=gnt_ft_a data-t-l=:f|v|c|about:california-privacy-right>Your California Privacy Rights / Privacy Policy</a><button class="gnt_ft_a gnt_ft_a__bl" data-g-r=base_ottid data-t-l=:f|v|c|about:cookie-policy>Do Not Sell My Info / Cookie Policy</button></div><div class=gnt_ft_ls aria-label=Support><a href=https://help.waltonsun.com/contact-us class=gnt_ft_a data-t-l=:f|v|c|support:contact-us>Contact Us</a> <a href=https://supportlocal.usatoday.com/ class=gnt_ft_a data-t-l=:f|v|c|support:support-local-businesses>Support Local Business</a> <a href=https://localiq.com/markets/florida/santa-rosa-beach/ class=gnt_ft_a data-t-l=:f|v|c|support:advertise-your-business>Advertise Your Business</a> <a href=https://cm.waltonsun.com/advertising-terms-conditions class=gnt_ft_a data-t-l=:f|v|c|support:advertising-terms-and-conditions>Advertising Terms and Conditions</a> <a href=http://www.verican.us/cod6/nwfdailynews class=gnt_ft_a data-t-l=:f|v|c|support:buy-and-sell>Buy and Sell</a> <a href=https://imagn.com/licensing-reprints/ class=gnt_ft_a data-t-l=:f|v|c|support:licensing-and-reprints>Licensing & Reprints</a> <a href=https://help.waltonsun.com/ class=gnt_ft_a data-t-l=:f|v|c|support:help-center>Help Center</a> <a href=https://account.waltonsun.com/ class=gnt_ft_a data-t-l=:f|v|c|support:my-account>My Account</a> <a href=https://cm.waltonsun.com/site-feedback/ class=gnt_ft_a data-t-l=:f|v|c|support:feedback>Give Feedback</a> <a href="https://gmiiservices.newscyclecloud.com/cgi-bin/cmo_gmi-c-cmdb-fla-01.sh/custservice/web/login.html?siteid=WSU" class=gnt_ft_a data-t-l=:f|v|c|support:my-print-account>My Print Account</a></div><div class=gnt_ft_ls aria-label="Stay Connected"><a href=https://subscribe.waltonsun.com/ class=gnt_ft_a data-t-l=:f|v|c|stay-connected:subscribe-today>Subscribe Today</a> <a href=https://profile.waltonsun.com/newsletters/manage class=gnt_ft_a data-t-l=:f|v|c|stay-connected:newsletters>Newsletters</a> <a href=http://www.facebook.com/waltonsun class=gnt_ft_a data-t-l=:f|v|c|stay-connected:facebook>Facebook</a> <a href=http://www.twitter.com/waltonsun class=gnt_ft_a data-t-l=:f|v|c|stay-connected:twitter>Twitter</a> <a href=https://user.waltonsun.com/user/enewspaper class=gnt_ft_a data-t-l=:f|v|c|stay-connected:e-edition>E-Edition</a></div><div class=gnt_ft_ls aria-label="Our Partners"><a href=/jobs class=gnt_ft_a data-t-l=:f|v|c|our-partners:jobs>Jobs</a> <a href=/section/cars class=gnt_ft_a data-t-l=:f|v|c|our-partners:cars>Cars</a> <a href=/homes class=gnt_ft_a data-t-l=:f|v|c|our-partners:homes>Homes</a> <a href=http://marketplace.waltonsun.com/classifieds/ class=gnt_ft_a data-t-l=:f|v|c|our-partners:classifieds>Classifieds</a> <a href=https://www.reviewed.com/ class=gnt_ft_a data-t-l=:f|v|c|our-partners:reviewed>Reviewed.com</a> <a href=https://www.10best.com/ class=gnt_ft_a data-t-l=:f|v|c|our-partners:10best>10Best</a> <a href=http://www.reachlocal.com/us/en class=gnt_ft_a data-t-l=:f|v|c|our-partners:reach-local>Reach Local</a></div></div><div class=gnt_ft_cr elementtiming=footer-cr>© 2021 www.waltonsun.com. All rights reserved.</div></footer><script>if(gnt.luxEnabled&&(LUX={ae:[],al:[]},setTimeout(function(){gnt.addScript('/tangstatic/js/perf-q1a2z3b18338f8.min.js',!0)},3E3),addEventListener("error",a=>{LUX.ae.push(a)}),"function"===typeof PerformanceObserver))try{LUX.al.po=new PerformanceObserver(a=>{LUX.al.push(...a.getEntries())}),LUX.al.po.observe({type:"longtask",buffered:!0})}catch(a){};</script><script>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</script><script async src=/tangstatic/js/main-q1a2z3223907d6.min.js onerror="document.querySelectorAll('.gnt__hbd').forEach(e=>e.classList.remove('gnt__hbd'))"></script><script type="gnt/tmpl" data-tmpl-key=navgdp><div class="gnt_n_dd_oy gnt_n_dd__sz" data-g-r=nav_oy></div><div class="gnt_n_dd gnt_n_dd__sz" data-g-r="nav_dd nav_te nav_ff" tabindex=0></div>|styles|[data-g-s=nav_ao] .gnt_n_dd_bt_svg{transform:rotate(180deg);background:currentColor;fill:#303030}.gnt_n_dd_oy{display:none;left:0;right:0;height:calc(var(--gnt-vh,100vh) - 100px - var(--gnt-sh,0px))}.gnt_n_dd{overscroll-behavior-y:contain;overflow:auto;overflow-x:hidden;box-sizing:border-box;display:none;width:385px;height:calc(var(--gnt-vh,100vh) - 100px - var(--gnt-sh,0px));margin:0 0 0 -20px;padding:7px 20px 0 32px;border-top:5px solid #0098fe;background:#303030;color:#fff}[data-g-s=nav_ao] .gnt_n_dd__sz{display:block;position:absolute}</script><script type="gnt/tmpl" data-tmpl-key=navse><form class=gnt_n_se_fm data-g-r=nav_dd action=/search/ role=search><input class=gnt_n_se_fm_qr data-g-r=nav_pf name=q placeholder="What can we help you find?" mozactionhint=search enterkeyhint=search aria-label="Search query"/><button class=gnt_n_se_fm_sm data-t-l=${se}:r|r|u| aria-label=Submit><svg class=gnt_n_se_fm_sm_svg viewBox="0 0 18 18"><path d="M12.28 9.76H2V7.74h10.28l-2.23-2.31L11.43 4 16 8.75l-4.57 4.75-1.38-1.43 2.23-2.31z"/></svg></button></form>|styles|.gnt_n_se_fm{display:none;align-items:center;justify-content:center;position:absolute;left:0;right:0;height:180px;padding:0 0 15px;border-top:5px solid #0098fe;background:#303030}[data-g-s~=nav_ao] .gnt_n_se_fm{display:flex}.gnt_n_se_fm_qr{width:492px;height:46px;padding:0 50px 0 0;border-style:solid;border-width:0 0 2px;border-color:#fff;border-radius:0;outline:0;background:0 0;color:#fff;font:700 28px 'Unify Sans','Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif}.gnt_n_se_fm_qr::placeholder{opacity:1;color:#fff}.gnt_n_se_fm_qr:-webkit-autofill{box-shadow:inset 0 46px #303030;-webkit-text-fill-color:#fff}.gnt_n_se_fm_sm{width:60px;height:50px;border:0;margin:0 -15px 0 -45px;padding:0;outline-offset:-8px;fill:#fff;background:0 0;cursor:pointer}.gnt_n_se_fm_sm:hover{fill:#e0e0e0}.gnt_n_se_fm_sm_svg{width:42px;height:42px;margin-top:3px;stroke:#303030;stroke-width:.5px}</script><link rel=preload as=fetch type=application/json crossorigin=use-credentials href=/global-q1a2z3fliKY7hSAoRxlKG04BEHV8Tk3j0.min.json /><link rel=dns-prefetch href=//images.taboola.com /><link rel=preconnect href=https://images.taboola.com /><script type=application/ld+json>[{"@context":"http://schema.org","@type":"NewsArticle","headline":"DESTIN EVENTS AND ENTERTAINMENT March 20","description":"DESTIN EVENTS AND ENTERTAINMENT March 20","url":"https://www.waltonsun.com/story/entertainment/2021/03/18/destin-events-and-entertainment-march-20/4747189001/","mainEntityOfPage":{"@type":"WebPage","@id":"https://www.waltonsun.com/story/entertainment/2021/03/18/destin-events-and-entertainment-march-20/4747189001/"},"thumbnailUrl":"https://www.gannett-cdn.com/presto/2020/08/13/NDES/94f13d98-9aee-4f68-84be-667c04ad6977-log_com_calendar.jpg?crop=168,168,x29,y0&width=150&height=150&format=pjpg&auto=webp","image":{"@type":"ImageObject","url":"https://www.gannett-cdn.com/presto/2020/08/13/NDES/94f13d98-9aee-4f68-84be-667c04ad6977-log_com_calendar.jpg?crop=297,168,x0,y0&width=297&height=148&format=pjpg&auto=webp","height":800,"width":1600},"datePublished":"2021-03-18T14:19:17Z","dateCreated":"2021-03-18T14:19:17Z","dateModified":"2021-03-18T14:19:17Z","articleSection":"entertainment","publisher":{"@type":"Organization","name":"The Destin Log","logo":{"@type":"ImageObject","url":"https://www.gannett-cdn.com/sites/waltonsun/images/site-nav-logo@2x.png"}},"author":["Pam Griffin"],"keywords":["access:metered","ssts:entertainment","type:story","tag:Entertainment","tag:Overall Very Positive"],"isAccessibleForFree":true,"isPartOf":{"@type":["CreativeWork","Product"],"name":"The Destin Log - Unlimited Digital Access","productID":"waltonsun.com:standard"},"metadata":"{\"id\":\"4747189001\",\"siteCode\":\"NWAL\",\"contentSourceCode\":\"NDES\",\"ssts\":\"entertainment\",\"type\":\"story\"}"},{"@context":"http://schema.org","@type":"ImageObject","url":"https://www.gannett-cdn.com/presto/2020/08/13/NDES/94f13d98-9aee-4f68-84be-667c04ad6977-log_com_calendar.jpg","caption":"Community events, entertainment","copyrightHolder":"[CONTRIBUTED PHOTO]"}]</script></body></html>